Jump to content
TEAM SHELBY FORUM

Fuel problem


bdaztrk
 Share

Recommended Posts

Checking to see if anyone has had this problem before.. 2011 model When the fuel gauge gets to half a tank the needle drops all the way to empty and it says 0 miles to go. The first time it happened it went to a gas station and left the key on to watch the gauge and after 2 gallons it went back the 3/4 tank. So I thought the tank lever might have just got stuck Today i was 7 miles from a station and it hit half a tank and showed like 125 miles or so until empty and then it did it again went to empty so i thought it had plenty of fuel but 3 miles down the road it went to bucking and backfiring like no fuel, It made it to the station doing that about got rearended, put 2 gallons in it again and went back to 3/4 tank and runs fine..Went to ford place cause i had a check engine light now and they said sensor and fuel rail pressure, so even if there is that much fuel in tank would the car still act like its empty and they said it could be pump issue also. Just checking to see other thoughts before they do the whole computer check point test that they said would take all day

Link to comment
Share on other sites

Also the other day just to check to see if fuel gauge was right it was at almost half and i went to fill up and it only to a few gallons to kick off the pump so i know the gauge is right and it has a half a tank when this starts showing E and no miles left

Edited by bdaztrk
Link to comment
Share on other sites

Checking to see if anyone has had this problem before.. 2011 model When the fuel gauge gets to half a tank the needle drops all the way to empty and it says 0 miles to go. The first time it happened it went to a gas station and left the key on to watch the gauge and after 2 gallons it went back the 3/4 tank. So I thought the tank lever might have just got stuck Today i was 7 miles from a station and it hit half a tank and showed like 125 miles or so until empty and then it did it again went to empty so i thought it had plenty of fuel but 3 miles down the road it went to bucking and backfiring like no fuel, It made it to the station doing that about got rearended, put 2 gallons in it again and went back to 3/4 tank and runs fine..Went to ford place cause i had a check engine light now and they said sensor and fuel rail pressure, so even if there is that much fuel in tank would the car still act like its empty and they said it could be pump issue also. Just checking to see other thoughts before they do the whole computer check point test that they said would take all day

 

 

This was an issue with a few other members and their 2010's.. I dont think it was a big deal to fix...

 

M.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...