Jump to content
TEAM SHELBY FORUM

blower belt coming apart


Recommended Posts

KB

 

 

same thing happened to me about 1 month ago. I only have about 3K miles on my SS. 2.8 KB w/3" pulley. i went ahead and replaced the serpentine belt at the same time. took all hoses off the front of the motor so that i could check for any pulley alignment issues but i did not see any. I am watching my new belt closely to see if the issue comes up again. Has anyone else had this issue? anyone out there got any tips for what might be the cause? i posted early pics of my belt breaking down previously in the SS section in another thread.

 

Ron

Link to comment
Share on other sites

same thing happened to me about 1 month ago. I only have about 3K miles on my SS. 2.8 KB w/3" pulley. i went ahead and replaced the serpentine belt at the same time. took all hoses off the front of the motor so that i could check for any pulley alignment issues but i did not see any. I am watching my new belt closely to see if the issue comes up again. Has anyone else had this issue? anyone out there got any tips for what might be the cause? i posted early pics of my belt breaking down previously in the SS section in another thread.

 

Ron

 

this is the second belt i think in 6500 miles had to quit at the track yesterday because of it

Link to comment
Share on other sites

same thing happened to me about 1 month ago. I only have about 3K miles on my SS. 2.8 KB w/3" pulley. i went ahead and replaced the serpentine belt at the same time. took all hoses off the front of the motor so that i could check for any pulley alignment issues but i did not see any. I am watching my new belt closely to see if the issue comes up again. Has anyone else had this issue? anyone out there got any tips for what might be the cause? i posted early pics of my belt breaking down previously in the SS section in another thread.

 

Ron

 

 

Ron,

 

The stock KB pulley for a 725 SS is 2.5" in diameter. I'm wondering if changing to the 3.0" pulley is causing some of the problem? Are you using the same length belt for the 3" pulley?

 

Jim

Link to comment
Share on other sites

Ron,

 

The stock KB pulley for a 725 SS is 2.5" in diameter. I'm wondering if changing to the 3.0" pulley is causing some of the problem? Are you using the same length belt for the 3" pulley?

 

Jim

 

it was the belt they sent with the new 4 pound pulley i think

Link to comment
Share on other sites

Ron,

 

The stock KB pulley for a 725 SS is 2.5" in diameter. I'm wondering if changing to the 3.0" pulley is causing some of the problem? Are you using the same length belt for the 3" pulley?

 

Jim

 

Stock pulley for the 725hp SS is 3.25 dia. At least it was on 07SS0134.

Edited by MY500SS
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...