Jump to content
TEAM SHELBY FORUM

Need a few suggestions for shops in Spring, TX area


rown4au
 Share

Recommended Posts

Hi well after several months of waiting we are finally in our new place in Spring, TX. Now that the shelby is down here I need to get it inspected and get Texas plates on it. I am not keen on the idea of just handing it over to just anyone so if anyone can suggest a good dealer or shiop to take it to for the inspection I would be grateful.

 

We also need a decent body shop locally as well as the wife had a small encounter with a concrete pole in my truck today. Luckily nothing serious but I think I may now need a new front bumper and a bit of paint work...

 

thanks;

 

Jaime

Link to comment
Share on other sites

Jamie, get the Shelby's inspection here:

 

Mr Sticker

15113 Welcome Ln, Houston, TX 77014 (281) 444-4440

 

They take good care of the car and you can see it at all times.

 

Body shop I used for the Shelbys bumper is in Katy. Let me know if you are interested in going that far.

Link to comment
Share on other sites

Jamie,

 

You can also take it to the Shell Station on the corner of FM 1960 and Pardise Valley.. It's located between Champion Forest and Stubner Airline.

This station is owned by a father son combo. I know the son Fred and he has always performed the inspections on my past cars and will be doing the inspection on my Shelby at the end of this Month.

 

Dwight

Link to comment
Share on other sites

Jaimie,

 

All good choices. I have a Performance shop in Spring and can take care of any mechanical issues. I have taken all my cars, including the Shelby's to Splash and Dash (1707 Spring Cypress Rd, Spring, TX 77388-3613 -281 288-3001). On FM2920. They will even wash your car by hand for $15. Just up the road from them is one of our friends who has a body shop and does show quality work Accelerated Paint & Body

 

Louis

Edited by SGT-C0056
Link to comment
Share on other sites

Yes they will drive the car for the inspection. He only pulls it out of the parking lot onto Pardise Valley and turns around at the first driveway and comes back to the station.

You'll have to go to the court house for the plates and they are not open on Saturdays. Since your in Spring the court house is located at Cypresswood and Stubner Airline.

Link to comment
Share on other sites

Jaimie,

 

All good choices. I have a Performance shop in Spring and can take care of amy mechanical issues. I have taken all my cars, including the Shelby's to Splash and Dash (1707 Spring Cypress Rd, Spring, TX 77388-3613 -281 288-3001). On FM2920. They will even wash your car by hand for $15. Just up the road from them is one of our friends who has a body shop and does show quality work Accelerated Paint & Body

 

Louis

 

What's up Louis?? Are you up for the Coffee & Cars the following weekend?

Link to comment
Share on other sites

Jaimie,

 

All good choices. I have a Performance shop in Spring and can take care of amy mechanical issues. I have taken all my cars, including the Shelby's to Splash and Dash (1707 Spring Cypress Rd, Spring, TX 77388-3613 -281 288-3001). On FM2920. They will even wash your car by hand for $15. Just up the road from them is one of our friends who has a body shop and does show quality work Accelerated Paint & Body

 

Louis

 

 

HI Louis thanks for the info, where is your shop? Do you do strictly performance work or a bit of everything?

Link to comment
Share on other sites

Shop I use drives it around the building to test brakes and honk the horn. Then into the bay to hook up to the computer. That is it! Hand over $39.50 and be on your way.

 

 

Holy crap!!! $40 bucks?

 

Oh, the benefits of living in small town America. $14.50 and they have NEVER driven anything I have ever taken in for an inspection (although I think they are supposed to).

 

No smog or computer check here either.

Link to comment
Share on other sites

Holy crap!!! $40 bucks?

 

Oh, the benefits of living in small town America. $14.50 and they have NEVER driven anything I have ever taken in for an inspection (although I think they are supposed to).

 

No smog or computer check here either.

 

Living in the BIG city, we have to have the smog/computer hook up :)

Link to comment
Share on other sites

Check Engine Light

 

 

Well I don't have a check engine light and the computer isn't throwing any codes but it still failed.

 

:censored:

 

It passed everything fine until the emissions test results and the computer said the following read as "not ready" Catalyst, Evap, O2 Sens, and O2 Sens htr. I am a bit frustrated as I know it will pass a sniffer test but the shop I went to said that the state of Texas wouldn't allow it and it has to pass via the OBD sensor. The guy at the shop was great (thanks msmap/Sherri) he was very friendly and felt really bad about it but there wasn't anything he could do.

 

The car is running great, and has no problems with it so I am not sure what to do from here. I am going to send an email to Dennis at Tasca and ask him if he has any ideas as they did the work and try to get in touch with Quantum as they probably have dealt with this before.

 

If there is anyone out there who has any suggestions that is running a TVS with long tube headers and high flow cats in Texas I would appreciate it.

Link to comment
Share on other sites

Well I don't have a check engine light and the computer isn't throwing any codes but it still failed.

 

:censored:

 

It passed everything fine until the emissions test results and the computer said the following read as "not ready" Catalyst, Evap, O2 Sens, and O2 Sens htr. I am a bit frustrated as I know it will pass a sniffer test but the shop I went to said that the state of Texas wouldn't allow it and it has to pass via the OBD sensor. The guy at the shop was great (thanks msmap/Sherri) he was very friendly and felt really bad about it but there wasn't anything he could do.

 

The car is running great, and has no problems with it so I am not sure what to do from here. I am going to send an email to Dennis at Tasca and ask him if he has any ideas as they did the work and try to get in touch with Quantum as they probably have dealt with this before.

 

If there is anyone out there who has any suggestions that is running a TVS with long tube headers and high flow cats in Texas I would appreciate it.

 

 

Rown4au,

 

We do all types of automotive and electrical work. We build racecars also. Let me call my guy at Splash and Dash, they might be able to pass you....We send them lots of business and our one of our clients

Link to comment
Share on other sites

Long tubes can move the O2 sensors out farther from the engine making the not heat up. This could cause the computer to store a code. Do you have any codes? Could get them cleared and drive 100 miles or so. Did the movers disconnect your battery? If so, you may need to put some miles on it, to get the computer to relearn the car. Great weekend! Go drive your car!

Link to comment
Share on other sites

Long tubes can move the O2 sensors out farther from the engine making the not heat up. This could cause the computer to store a code. Do you have any codes? Could get them cleared and drive 100 miles or so. Did the movers disconnect your battery? If so, you may need to put some miles on it, to get the computer to relearn the car. Great weekend! Go drive your car!

 

 

No they said the computer was not throwing any codes, movers did not disconnect the battery and it was sitting in a garage under a cover with a battery tender on it since mid October so battery was never dead. The last time the battery might have been disconnected would have been when it was at Tasca's shop to sort out a few things which I think was in August but the records are in one of our moving boxes of files at the moment. Either way the car has definitely been driven more than 100 miles since that time probably 300-1000 as a guess.

Link to comment
Share on other sites

Well I don't have a check engine light and the computer isn't throwing any codes but it still failed.

 

:censored:

 

It passed everything fine until the emissions test results and the computer said the following read as "not ready" Catalyst, Evap, O2 Sens, and O2 Sens htr. I am a bit frustrated as I know it will pass a sniffer test but the shop I went to said that the state of Texas wouldn't allow it and it has to pass via the OBD sensor. The guy at the shop was great (thanks msmap/Sherri) he was very friendly and felt really bad about it but there wasn't anything he could do.

 

The car is running great, and has no problems with it so I am not sure what to do from here. I am going to send an email to Dennis at Tasca and ask him if he has any ideas as they did the work and try to get in touch with Quantum as they probably have dealt with this before.

 

If there is anyone out there who has any suggestions that is running a TVS with long tube headers and high flow cats in Texas I would appreciate it.

 

 

Well I hate to hear this since I'm running a TVS with LT's also... My inspection and registration ran out at the end of Feburary so I'll be hitting the inspection station soon

Link to comment
Share on other sites

Well I hate to hear this since I'm running a TVS with LT's also... My inspection and registration ran out at the end of Feburary so I'll be hitting the inspection station soon

 

 

Have spoken to Dennis at Tasca and think we have an easy fix. (fingers crossed) He is sending me a new tune and some spacers for the rear O2 sensors. He says this should solve the issue once I install both and run it through a complete drive cycle.

 

fingers crossed!!!!

Edited by rown4au
Link to comment
Share on other sites

Hey Jamie,

It was nice meeting you today....Thought I would let you know that mine did not pass the emission test today either... My test print out has the same issues as yours did...

 

 

Hi Dwight, was good to meet you as well. Sorry to hear about the emission issue with yours, I can relate to your frustration.

 

However, I have some potentially good news for you, after loading the new tune and rear O2 spacers my car passed today with flying colors and no issues. :happy feet:

 

Drop me a PM with your telephone number and will give you a call and we can discusss further. We should be able to get it sorted out pretty easily I think.

Edited by rown4au
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...