Jump to content
TEAM SHELBY FORUM

What is that disconcerting twitch?


thewheelman
 Share

Recommended Posts

My 07 vert is stone stock, no performance mods whatsoever. Last night, coming home, I'm doing about 40 in 3rd. The road is clear--it's 56 degrees, dry pavement and the traction control is off. So, I floor it and scream up to about 105 before I back off and there it is, all the way up, this disconcerting little twitch, like one wheel is grabbing and the other is not. Not enough to upset the car, mind you, but certainly enough to upset me. It's done this since brand new. No noise, and at those speeds I'm thinking not wheel spin, but this twitch, like the rear end is shifting or something. I only notice it at full throttle........ What is that?

Edited by thewheelman
Link to comment
Share on other sites

I would say your clutch is slipping. However, you state it has done this since new so I guess that is ruled out. I have had 2 GT500 and they both had the clutch TSB done. When I rolled on the throttle as you described I would feel that little wiggle and realize the clutch wouldn't hold the torque anymore.

Link to comment
Share on other sites

mine has done that same thing on diff. types of roads - on ramps usually . . . feels like something loose in the rear of the car . . no noise or steering wheel motions. Has done it with both clutches and both suspensions , very puzzling . . .

Link to comment
Share on other sites

I would say your clutch is slipping. However, you state it has done this since new so I guess that is ruled out. I have had 2 GT500 and they both had the clutch TSB done. When I rolled on the throttle as you described I would feel that little wiggle and realize the clutch wouldn't hold the torque anymore.

 

 

Just had 2010 clutch installed about 1000 miles ago.....but it did the same thing since new, original clutch, replacement clutch, 2010 clutch......

Link to comment
Share on other sites

  • 5 months later...

It doesn't do it with my drag radials on so it may be the stock tires?

 

 

Well, he did say it was about 56 degrees...I found that the Goodyear Eagle F1 Supercar tires will not stick to anything when temps are cool...I had a set on my 08 SGT on GT500 wheels, and when it was cool out here in West Texas, it took very little pressure on the pedal on the right to make the back end break loose...and that was on a basically stock 350 HP 4.6 motor...add another 150 HP to it and viola! I'll let ya know how my new GT500 does on these tires out here in West Texas when the temps get cool again...

Link to comment
Share on other sites

Can you say "live rear axle".

 

They all do that.

 

No they don't

can you say "new upper and lower control arms, lower relocation brackets and trosen rear end" The 07 is very stable with no twitching!! Now the 13 is twitching all over the road it needs fix.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...