Jump to content
TEAM SHELBY FORUM

Question?? RPM at high speed


SNKDOUT
 Share

Recommended Posts

I have the 3.6L Kenny Bell Super Charger. When I am running in 5th or 6th gear, I hit the peddle with over 7 PSI boost, and the engine revs and then takes off, Not sure if I am just spinning the tires of if there is something wrong? Any insite would be appreciated!

 

 

Sounds like a possible slipping clutch. Give me a call if you would like to discuss.

 

Van

Revan Racing

561-445-7702

Link to comment
Share on other sites

I have the 3.6L Kenny Bell Super Charger. When I am running in 5th or 6th gear, I hit the peddle with over 7 PSI boost, and the engine revs and then takes off, Not sure if I am just spinning the tires of if there is something wrong? Any insite would be appreciated!

 

 

Yeah, I totally agree with Van.

 

That is a classic symptom of a slipping clutch. You are about to buy a new clutch friction disc & pressure plate, and if you go too far, possibly a flywheel or a flywheel resurface/grind.

 

 

Phill

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...