Jump to content
TEAM SHELBY FORUM

Gauge problem


Recommended Posts

I have the Shelby - Autometer gauges on my dash that were installed by Quantum when i had my supercharger installed last April. The fuel pressure gauge quit working. I unpluged the sending unit and the needle on the gauge would go to 100 psi when i turn the key on. I checked the connection on the gauge and all seamed ok. I checked the connection to the sending unit and all ok also. I am getting juice from the gauge to the sending unit. I suspect the problem is with the sending unit but not sure. Anyone have a problem with there fuel pressure gauge. Thank's, Kenneth.

Link to comment
Share on other sites

That is correct. Kenneth and i actually talked about it at the Papas show. Mine started to act up when I was at Mid America, I thought it was the fuel, but it still does it. It reads zero, and then after the car is warm or I hit 100mph, it stars moving and bouncing around. So i know its connected properly.

 

I have not installed a SC yet, so I thought that was the reason. I think its a faulty fuel sendor and I dont know or what part it is to replace it with.

Link to comment
Share on other sites

Mine has been doing the same thing for a while now. I haven't really worked on it much but I expect the problem is the sending unit. I'm not really too happy with the gauges as a whole so the motivation to fix it isn't very high. :rant2:

Obviously i haven't had a lot of motivation either as this has been broke over 2 months but with the cost and installation i should of already had this taken care of. I talked to Quantum about 6 weeks ago and at first he thought it was the sending unit then became hesitant. Nov. 1 he decided he would send me a sending unit but i haven't heard back from him.I'll call him Monday to see what happened. It's to far to take the car to Dallas for what should be something minor. When i get the sending unit and install it i will let ya'll know if this was the problem. As for Louis's car, this probably is the same problem.

Link to comment
Share on other sites

If anyone else would like to comment about problems with there gauges then please do. I'm not sure the sending unit is the problem but i'm going to install a new one if i ever get it from Quantum. I'm getting power to the gauge and the sending unit so there should'nt be any problem in between and hopefully its not the fuel pressure gauge.

Link to comment
Share on other sites

Obviously i haven't had a lot of motivation either as this has been broke over 2 months but with the cost and installation i should of already had this taken care of. I talked to Quantum about 6 weeks ago and at first he thought it was the sending unit then became hesitant. Nov. 1 he decided he would send me a sending unit but i haven't heard back from him.I'll call him Monday to see what happened. It's to far to take the car to Dallas for what should be something minor. When i get the sending unit and install it i will let ya'll know if this was the problem. As for Louis's car, this probably is the same problem.

 

 

I hope the sending unit takes care of the problem. I would be happy to buy one outright if that solves it. The other reason for my lack of motivation is the dust on the inside of lenses on all three gauges. I'm curious if they can opened and cleaned. I personally didn't think that was possible...

 

Please let us know how yours turns out.

Link to comment
Share on other sites

I hope the sending unit takes care of the problem. I would be happy to buy one outright if that solves it. The other reason for my lack of motivation is the dust on the inside of lenses on all three gauges. I'm curious if they can opened and cleaned. I personally didn't think that was possible...

 

Please let us know how yours turns out.

 

Waiting on Quantum to send the part. They told me it should be mailed out this week but my patience is running thin. I'm glad i didn't take my car to Quantum to be fixed . I've been dealing with them over 2 months now.

Link to comment
Share on other sites

Let me know Ken and If you get a part number

 

Check with summitracing. They carry autometer sending units. I believe part number 2246 might be the correct part. This part is universal and it goes to 100 pounds, which is what our gauges go to.It also looks like our sending units in the picture. Never the less i will post the part number on the sending unit i get as soon as i receive it.

Link to comment
Share on other sites

  • 3 weeks later...

I decided to call Shelby after giving up on Quantum. I believe Quantum does good work but there customer service is the worst i have ever seen in my entire life . I have tried to deal with the owner for over 2 months and all i've gotten is lies. He is always going to call me back but never does. Obviously he never intended to honor the warranty on the gauges. I would never buy or deal with Quantum again.This company is an embarassment to Shelby. The lies started when i sent my deposit for the GT/SC package. I was told to send my deposit and they would order my supercharger immediately which i believe they did but they acted like it would be in any day. I didn't find out till later that whipple doesn't start building the units untill they receive the order.Quantum knew that but kept telling me the s/c should be in any day now. During the process the owner would never call me back. It was always me that made the phone calls. I was warned by several forum members that they were like this but i just couldn't believe anyone could be this bad with customer service.Shelby needs to pull there franchisse and let someone have it that would be proud to represent Shelby because Quantum has made a mockery of Shelby. As for the gauges, the owner told me 3 weeks ago this last Monday he would order the part that day just as soon as he got off the phone with me. Called him back 2 weeks later and he said he would check on it. He said he would call me right back. Still waiting on the call. As for Shelby, i called Roger and explained the problem and he told me he would have Craig Robinson who is the production manager call me back. Sure enough within 30 minutes Craig called me back and i explained the problem and he decided it probably was the sending unit. He mailed the part out that afternoon and called me also that afternoon to give me the tracking number. I received the part 6 days later which was Tuesday. I installed the part yesterday and the gauge works fine.This is the kind of customer service i'm use to. Obviously Quantum could take lessons from Shelby. Roger and Craig were great to work with and i would recommend these two guys to deal with if you were to have Shelby do anything to your car.It's just hard to believe there is some people representing Shelby that has total disregard for the customer like Quantum but at least Shelby has some good people who don't forget you after the sale. Thanks Roger and Craig for the professionalism you showed in dealing with me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...