Jump to content
TEAM SHELBY FORUM

Shifter Problem ?


viper97
 Share

Recommended Posts

I have had my 08 gt500 at the drag strip a few times and under full acceleration I miss 2nd practically every time unless I let all the way off the gas and ease into gear then accelerate again. I have had a couple buddies run the car also with the same issue so I do not believe it's me. The last time out the car also was hard to get in 3rd. When driving on the street no problems but not driving hard on the street. The car has a ram twin disc with their throwout bearing and a Shelby performance shifter. Thanks for any help.

Link to comment
Share on other sites

I have had my 08 gt500 at the drag strip a few times and under full acceleration I miss 2nd practically every time unless I let all the way off the gas and ease into gear then accelerate again. I have had a couple buddies run the car also with the same issue so I do not believe it's me. The last time out the car also was hard to get in 3rd. When driving on the street no problems but not driving hard on the street. The car has a ram twin disc with their throwout bearing and a Shelby performance shifter. Thanks for any help.

 

 

Input shaft or bad syncros maybe. If the clutch is good, sounds like the tranny to me.

Link to comment
Share on other sites

I have had my 08 gt500 at the drag strip a few times and under full acceleration I miss 2nd practically every time unless I let all the way off the gas and ease into gear then accelerate again. I have had a couple buddies run the car also with the same issue so I do not believe it's me. The last time out the car also was hard to get in 3rd. When driving on the street no problems but not driving hard on the street. The car has a ram twin disc with their throwout bearing and a Shelby performance shifter. Thanks for any help.

 

Welcome to the club. Most GT500s have this issue. No idea how to fix it.

Link to comment
Share on other sites

Welcome to the club. Most GT500s have this issue. No idea how to fix it.

 

 

I talked with a guy from tremic he said it's a bad design of the shifter (two mounting points on the trans then the other on the body letting it change angle under tork. ) They want to sell me a new tranny that just came out with the shifter built in the trans ($2800.00). He said he gets this complaint often. I will say my old 97 gts viper had the sifter in the trans (tremic 6 spd) and it never had a shifting problem. That car was stock and my Shelby is far from stock. Thanks

Link to comment
Share on other sites

  • 2 weeks later...

My car started doing the same thing last time I drove it. Yesterday I rolled her out for a bath and when I tried backing back into my garage reverses made a horrible grinding noise and was hard as hell to engage. I was hoping the stock clutch had finally gone but that doesn't sound like the case? ... :doh:

Edited by mr4teth
Link to comment
Share on other sites

  • 3 weeks later...

The syncros are shot in second and third gear. Mine is in the shop getting repaired. The test is the same for the warped flywheel TBS. With the motor running and the clutch out try to pull it into gear, if the syncros are good at best the motor will load up a little but it won’t go into gear. If they are shot then it will go past the syncros but stop and grind like hell when it hits the gears. Try this in all gears except reverse.

A simple repair but getting the bearings replaced is the expensive part as the metal that comes of the syncros and gears floats around in the oil which just becomes a polishing compound and microscopically attaches itself to the bearing surfaces. Get it repaired soon as it won’t heal up by itself.

Link to comment
Share on other sites

The syncros are shot in second and third gear. Mine is in the shop getting repaired. The test is the same for the warped flywheel TBS. With the motor running and the clutch out try to pull it into gear, if the syncros are good at best the motor will load up a little but it won’t go into gear. If they are shot then it will go past the syncros but stop and grind like hell when it hits the gears. Try this in all gears except reverse.

A simple repair but getting the bearings replaced is the expensive part as the metal that comes of the syncros and gears floats around in the oil which just becomes a polishing compound and microscopically attaches itself to the bearing surfaces. Get it repaired soon as it won’t heal up by itself.

 

 

Yes I took the trans out and took it to the tremec repair shop in FT Worth TX. They tore it down and the 2-3 syncros were shot. Getting it rebuilt with 2010 upgrades so hopefully it will work as it should.

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...