Jump to content
TEAM SHELBY FORUM

TPMS


tpenziner
 Share

Recommended Posts

In 2010, I thought Ford changed to valve stem sensor vs. the band type in previous years. I'm not sure if the sensors are interchangeable with the car, but you should be able put the new sensor on the Alcos. The older sensors, to me, are a waste. All they tell you is if you're under pressure. They don't tell you the actual tire pressure. I don't know if the newer set-up is better.

 

I would like to know how to turn the whole system off.

Edited by EL SHELBY
Link to comment
Share on other sites

In 2010, I thought Ford changed to valve stem sensor vs. the band type in previous years. I'm not sure if the sensors are interchangeable with the car, but you should be able put the new sensor on the Alcos. The older sensors, to me, are a waste. All they tell you is if you're under pressure. They don't tell you the actual tire pressure. I don't know if the newer set-up is better.

 

I would like to know how to turn the whole system off.

 

 

I am learning in this area so have no direction. I too would like to see the light go away. When I have track wheels on the car I see the light for weeks!

 

Good luck!

Link to comment
Share on other sites

I had an '08 GT500, and when I sold it, I kept my CCW wheels to put on my new '10. As mentioned, the TMPS sensors from the older (07-09) cars do NOT work with the '10-'11 cars, you do need to change to the new style.

I was trying to "train" my '10 with the old band-style sensors and it wouldn't work, that's how I discovered the "issue"

The training tool still works on the new cars, just the sensors are not compatible...

Bought 4 new sensors and stems and the warning light is gone...

Link to comment
Share on other sites

I had an '08 GT500, and when I sold it, I kept my CCW wheels to put on my new '10. As mentioned, the TMPS sensors from the older (07-09) cars do NOT work with the '10-'11 cars, you do need to change to the new style.

I was trying to "train" my '10 with the old band-style sensors and it wouldn't work, that's how I discovered the "issue"

The training tool still works on the new cars, just the sensors are not compatible...

Bought 4 new sensors and stems and the warning light is gone...

 

Thank you for confirmation on this. How much are new sensors?

Edited by tpenziner
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...