Jump to content
TEAM SHELBY FORUM

I still have the Chirp/Thud in front suspension!!


Recommended Posts

I purchased my car back in Feb. First thing i noticed is the thud sound coming from the front suspension. Then, I noticed the chirp going over bumps. It is driving me mad! And guess what? My car was built two months AFTER the time span of vehicles suspected to have the problem!!! Has anyone else had this problem? I'm taking it in next week, but there is no way my car has the new lca parts in it, since i'm having so much noise.

 

Please help!!

 

k

Link to comment
Share on other sites

I purchased my car back in Feb. First thing i noticed is the thud sound coming from the front suspension. Then, I noticed the chirp going over bumps. It is driving me mad! And guess what? My car was built two months AFTER the time span of vehicles suspected to have the problem!!! Has anyone else had this problem? I'm taking it in next week, but there is no way my car has the new lca parts in it, since i'm having so much noise.

 

Please help!!

 

k

 

 

 

Let us know what you find out. I gave up. My '08 has the new LCA's, replaced struts, and strut mounts, and it stil does something I don't think it should. Thud's over bumps..... Ford gave up and extended my warranty....yipee!!! (kidding).....

Link to comment
Share on other sites

Hope your able to figure it out. My 2010 has been quite as a mouse, I did have the new LCA's installed to be safe in the future. So far everything is still perfect. Good Luck, I had a vibration in third gear on deceleration in my 07 Shelby GT that drove me nuts, never could figure it out even after a new trans.

Edited by OneTrickPony
Link to comment
Share on other sites

yeah, keep us posted. mine has similar symptoms but no chirp sound. just a slight thud goin over bumps. i may not take mine in since the turbo build is fixin to start and i plan to run aftermarket arms later on but depending on what you find out, i may go ahead and run it to the dealership.

Link to comment
Share on other sites

yeah, keep us posted. mine has similar symptoms but no chirp sound. just a slight thud goin over bumps. i may not take mine in since the turbo build is fixin to start and i plan to run aftermarket arms later on but depending on what you find out, i may go ahead and run it to the dealership.

 

If you install a good aftermarket LCA you should be good shape if. All your getting is a improved hydo-bushing and very slight increase in the ball joint shaft size 0.74 to 0.75. I quess most of us have been pretty fortunante not to have any issues.

Link to comment
Share on other sites

If you install a good aftermarket LCA you should be good shape if. All your getting is a improved hydo-bushing and very slight increase in the ball joint shaft size 0.74 to 0.75. I quess most of us have been pretty fortunante not to have any issues.

 

 

 

im gonna install the rest of my front suspension first to make sure its not in the upper mount or else where. i dont think im gonna worry about the ball joint upgrade as i dont think that will be the big issue

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...