Jump to content
TEAM SHELBY FORUM

Car Going Into Fail Safe Mode - Why?


idrathergolf
 Share

Recommended Posts

I have a friend that had his car upgraded to a GT SC with a Kenne Bell supercharger and has had nothing but problems. He recently told me that his car would go into fail safe mode; he also has some temperature issues. I really feel bad about his situation. Anybody out there have similar issues with the work done by SAI? I told him to get his car tuned by Jon Lund and forget about the tune provided by KB.

 

What about the heat soak issues for the SC? Anybody had this problem and what was the solution? Shelby HE?

 

Just the other day we propped up the hood only to find coolant sprayed over the engine. It came from the cap of the coolant tank. What is causing this issue?

 

Also, what RWHP are you guys getting with the KB. He has about 425 and he thinks that is too low. KB told him he would get 500. Another disappointment.

Link to comment
Share on other sites

I have a friend that had his car upgraded to a GT SC with a Kenne Bell supercharger and has had nothing but problems. He recently told me that his car would go into fail safe mode; he also has some temperature issues. I really feel bad about his situation. Anybody out there have similar issues with the work done by SAI? I told him to get his car tuned by Jon Lund and forget about the tune provided by KB.

 

What about the heat soak issues for the SC? Anybody had this problem and what was the solution? Shelby HE?

 

Just the other day we propped up the hood only to find coolant sprayed over the engine. It came from the cap of the coolant tank. What is causing this issue?

 

Also, what RWHP are you guys getting with the KB. He has about 425 and he thinks that is too low. KB told him he would get 500. Another disappointment.

 

Your friend has problems....

My '07 SGT had 278 RWHP at the start.....I ended up with 451 RWHP and ~511 HP at the engine. Where do you live? Call KB and ask for the location of a shop that can help your friend. I know there is a SHop NW of Atlanta that is a Beta test site they use. I don't think I would risk the engine to get there. Check your PM

Grady

Link to comment
Share on other sites

Your friend has problems....

My '07 SGT had 278 RWHP at the start.....I ended up with 451 RWHP and ~511 HP at the engine. Where do you live? Call KB and ask for the location of a shop that can help your friend. I know there is a SHop NW of Atlanta that is a Beta test site they use. I don't think I would risk the engine to get there. Check your PM

Grady

PM checked. He lives in San Jose and has already worked very extensively with KB and drove his car to Sacramento under instruction by KB to work on the car. They got it to work but he isn't happy with the HP, temp issues, and car going into fail safe mode.

Link to comment
Share on other sites

Thanks, I'll pass your advice on. 485 RWHP on 91 octane?

Which shop in Sac did he see?

Was the coolant from the intercooler reservoir? If so, that's fairly common on the track anyway. When they get real hot and under too much pressure, they 'pop-off' as a safety. Is this happening during normal driving or very heavy throttling?

 

Ken

Link to comment
Share on other sites

Which shop in Sac did he see?

Was the coolant from the intercooler reservoir? If so, that's fairly common on the track anyway. When they get real hot and under too much pressure, they 'pop-off' as a safety. Is this happening during normal driving or very heavy throttling?

 

Ken

Ken,

 

It squirts out coolant jsut under normal driving conditions. He complains about temperature and 07-2937 commented that the car will go into fail safe when the fans are not connected, so I wonder if the problem is that the fans are not running properly and the car is heating up. Sounds like there can be a connection between the leaking coolant and the fail safe mode.

 

I don't know the shop in Sacramento but I'll ask him.

 

Dana

Link to comment
Share on other sites

Ken,

 

It squirts out coolant jsut under normal driving conditions. He complains about temperature and 07-2937 commented that the car will go into fail safe when the fans are not connected, so I wonder if the problem is that the fans are not running properly and the car is heating up. Sounds like there can be a connection between the leaking coolant and the fail safe mode.

 

I don't know the shop in Sacramento but I'll ask him.

 

Dana

 

DANA,

I reread the thread, the car is down on HP. The water leak should not be tied into the HP problem, but seperate. Has your friend talked with K Cristy (sp) at KB. Also, I found if you post on the KB section of this site you can expect they read the post especially if there is a problem. I had an issue with the removing the SAI SGT developed program and getting the correct FORD GT program back in the car, before you upload the KB developed program. The car would not run well, but I never had a 'limp back' issue. Again the leak is a separate issue I feel.

Also, I was told by KB that we should not go over 10psi boost as we are at the upper limit at 10 pounds of boost--and limited by the present lower end engine components. Change those parts to forged and you can make more power....but at a cost of engine longevity. The 5.4L SC was made for SC and I seen some 780hp RWHP 5.4s but why in a 3900# car? My SGT/SC will run all over my GT500 (w/ improved suspension) at VIR and those are the roads I drive on. It is not so much the HP as the torque and how it gets it down to the road...ask Porsche?

Grady

Link to comment
Share on other sites

ANOTHER AREA WHICH CAN CAUSE SIMILAR SYMTOMS IS

 

THE THERMOSTAT NOT OPENING AND THEN CAUSING A

 

OVERHEATING CONDITION AND FAIL SAFE MODE.

 

 

FURTHER MORE I BELIEVE THE THERMOSTAT IS

 

REPLACED TO A 160 THERMO WHEN RECIEVING THE GT/SC PACKAGE. SO

 

MAYBE THATS WHERE THE PROBLEM LIES IF IT'S NOT THE COOLING FANS.

 

 

SCOTTY

Link to comment
Share on other sites

ANOTHER AREA WHICH CAN CAUSE SIMILAR SYMTOMS IS

 

THE THERMOSTAT NOT OPENING AND THEN CAUSING A

 

OVERHEATING CONDITION AND FAIL SAFE MODE.

 

 

FURTHER MORE I BELIEVE THE THERMOSTAT IS

 

REPLACED TO A 160 THERMO WHEN RECIEVING THE GT/SC PACKAGE. SO

 

MAYBE THATS WHERE THE PROBLEM LIES IF IT'S NOT THE COOLING FANS.

 

 

SCOTTY

 

Thanks Scott. By the way, the cooling tanks I bought from you have been installed and working great.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...
...