Jump to content
TEAM SHELBY FORUM

Thermostat replacement-Definative answer anyone?


pmorritt

Recommended Posts

So, several months ago changed out the oem stat with the Napa 109 180d one. also changed fan sensor setting to come on at lower than stock setting. All seems well. Now I read that the Napa stat (180) is for the 4.6motor and does not open sufficiently-too short- to completely bypass the hot coolant and just flow cooler radiator coolant. Whats the real scoop here? Just internet -TOOA :talkhand: - stuff? Looks like someone has come up with a 170stat that "opens all the way"?? Is there an honest answer to this? Oh, btw, put on J&M upper and lower control arms last month- happy to say that there is NO wheel hop with wot in lower gears, She just squats, burns a little rubber and goes! Very pleased with the new stuff-----But, noticed some gear whine -didn't hear it before arm replacement- I'm thinking the poly bushings-much more solid that the oem rubber ones-allow more transmission of noise.

Link to comment
Share on other sites

I'm running a 160F thermostat with no issues.

I was running a 160 from Lethal with no issues on the street. However, on the track (road course) I was still seeing ECT's in the 220 ranges and IAT2s around 160. I pulled it completely and blocked the bypass and am running 20 degrees cooler ECT and 10-20 degrees cooler IAT2 on the track. It runs around 168 ECT with or without the stat in when warmed up.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...