Jump to content
TEAM SHELBY FORUM

Gas pedal or throttle binding issue


kimbray

Recommended Posts

All,

 

I have a 2007 GT500 that only has about 5k miles on it. Monday of this week, I was at a stop light and whn it turned green, I accelerated quickly and shifted to second. Even beofre I engaged second, the car's RPMs shot into red zone and the engine raced. Luckily I did not get into second gear, otherwise I would have flown into the car in front of me at full force.

 

The only way I could stop the engine from staying red lined was to turn off the ignition. Even after pulling over, I turned the engine over and the car went right back red lined! I turned the engine off again, pressed the gas pedal a few times and then turned the car back on. The problem cleared.

 

BUT it has now done this three times this week. I am taking it in. It seems to happen when I start pushing her a little hard. When I lay off the gas, it seems to be OK.

 

Any ideas???

 

Thanks.

 

Kimbray

Link to comment
Share on other sites

Believe I'd get that checked out asap. If I'm right, the GT 500 has the Ford "flybywire" system and there's not a real cable between the throttle body and the accelerator--it's all sensor and electronics. Sounds like a hiccup in your electrical system.

Link to comment
Share on other sites

I do have a custom tune from Fred and Evolution Performance. I have a CAI and a tune that is it. No pulley swap out or anything else.

 

Before I take to dealer, should I convert back to stock?

 

I checked the carpet thing, not the case. Carpet in locked position.

Link to comment
Share on other sites

I bet you a dollar it's in the tune. If you put your stock air filter back on and reload the stock tune I almost guarantee you it won't happen. Try that and if it doesn't do it, call Fred and ask for a revised tune. I think a lot of tuners have dealt with this problem. Especially if your tune is that old. They may not have know how to fix the problem (or that one even exist) 2 years ago. Hope you get it figured out. It's scary watching that tach climb like that huh!

Link to comment
Share on other sites

Hey Kimbray,

 

I think it may be in the tune, but also with the electrical wiring.

 

Mine occasionally does this, but especially if the air conditioning is on. If the air conditioning is not on, then it rarely will happen. If it happens with the air conditioning on, then if you turn the a/c off, the reving will go away.

 

Also, you can reflash your tune, and this will also correct it for a while.

 

My tune is also an older one, being downloaded to my tuner June of 2008.

Link to comment
Share on other sites

All,

 

I have a 2007 GT500 that only has about 5k miles on it. Monday of this week, I was at a stop light and whn it turned green, I accelerated quickly and shifted to second. Even beofre I engaged second, the car's RPMs shot into red zone and the engine raced. Luckily I did not get into second gear, otherwise I would have flown into the car in front of me at full force.

 

The only way I could stop the engine from staying red lined was to turn off the ignition. Even after pulling over, I turned the engine over and the car went right back red lined! I turned the engine off again, pressed the gas pedal a few times and then turned the car back on. The problem cleared.

 

BUT it has now done this three times this week. I am taking it in. It seems to happen when I start pushing her a little hard. When I lay off the gas, it seems to be OK.

 

Any ideas???

 

Thanks.

 

Kimbray

Could be an early sign of clutch failure.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...