Jump to content
TEAM SHELBY FORUM

Have to replace heat exchanger pump.


Recommended Posts

I will be replacing the pump on my heat exchanger tomorrow after 2 months use. About a week after I had my sc installed I started hearing a slight noise coming from the area of where the pump is located that I could only hear when the car was at an idle but has since gotten steadily louder to the point that something has to be done. I called KB and they sent me another pump, a spare belt and a free bottle of oil. The sc has performed flawlessly except for the loud pump and I can’t complain about KB’s service after the sale, the tech spent a fair amount of time with me and answered all my questions. I did have to pay a $150 core on the pump that is refundable once the old pump is sent back and test bad. Has anyone else here had a pump go bad?

 

Jeff

Link to comment
Share on other sites

I have had no problem. How many S/C miles do you have on the car?

Jim

 

About 525 miles, I should have it replaced by this afternoon and will see if the new pump cures it. I think it is a fluke even though the KB tech sounded like he has seen this before and the fact that I noticed that something might be wrong from the start. This was my first blower and I thought that the noise that I was hearing was something that just went with having a sc since it was not that loud at first and you can only hear it from inside the car while sitting at an idle. Another thing that I noticed is that my boost gauge is pegging closer to 10# than 9#, (might be that I just now got the balls to really look it). I’m going to take it back to my shop and have a couple of pulls done next weekend and maybe a custom tune while I’m there.

 

Jeff

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...