Jump to content
TEAM SHELBY FORUM

Shifter became soft and feels broken...


Recommended Posts

I searched and didn't see anyone else have this problem... I was driving the car tonight to my finace's house, as I shifted to 5th, the shifter became "soft" and it wouldn't shift into 5th. I rolled to a stop and shut off the car. The shifter was still very sloppy and wouldn't find any gear... I finally found 2nd and limped home.

 

I will be calling the dealer tomorrow and will keep you informed.

 

Jim

Link to comment
Share on other sites

There are posts here somewhere about it - but I've never found the search function to be user-friendly. There's a couple of nuts or bolts that can come loose, and its most important (obviously) to use loc-tite and proper torque.

Link to comment
Share on other sites

Its not a clutch cable, the shifter itself is very loose and if I wanted, I could pull it right off the tranny. I wanted to fix it myself as well, but if any damage was done to the tranny, I'd rather have the dealership fix it. I had it flatbedded to the dealership this afternoon and when they call me tomorrow, I'll fill you all in. Thanks for the support!

 

Jim

Link to comment
Share on other sites

It was confirmed, it was the shift linkage... the bolts just came out. They will fix and have it ready by Monday. Too bad they didn't get it done sooner, this may be close to the last 70 degree weekend in northern ohio... Anyway, thanks again!

 

Jim

Link to comment
Share on other sites

It was confirmed, it was the shift linkage... the bolts just came out. They will fix and have it ready by Monday. Too bad they didn't get it done sooner, this may be close to the last 70 degree weekend in northern ohio... Anyway, thanks again!

 

Jim

 

Another good ending

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...