Jump to content
TEAM SHELBY FORUM

Took shelby to Edmonton track last night


Steve.k

Recommended Posts

:happy feet: Took the Shelby to track last night and first run out was a 12.70 at 114 ,thats with Evo stage 1 and Nitto drag tires.The next four runs I couldnt get under !3.0 at 111,I noticed some of you guys talking about heat soak with the blower and you had a fix for it but I can't remeber what it was?There was a couple Shelbys there one with Stage 2 and he ran 12.65 and another with a complete new exhaust,headers and smaller pulley and lca's with stock tires and trac contol on he ran 11.65 wow! Had lots of fun but need to work on burnout as it is alittle tough with no line lock.Any Ideas why the car lost 3mph?and wouldn't pick back up?

Thanks Steve

Also are air density was at 4900ft :shift:

Link to comment
Share on other sites

Any Ideas why the car lost 3mph?and wouldn't pick back up?

Thanks Steve

Also are air density was at 4900ft :shift:

 

 

There you have it! When I last ran my car in Tucson/Phoenix last May & June the air density was well over 4,000' and the best I could do was low 13s. consider myself a novice driver too, so that might have some impact also.

 

Getting my car back from AZ in 2 weeks, then out on the track. Back to near sea level altitudes and cooler air temps later this fall. Looking for that first 12s run in stock configuration, and then work my way toward 11s with minimal mods.

 

Keith

Link to comment
Share on other sites

I ran mine last night, it's stock front to back and it ran 12.90 at 111mph but that damn wheel hop causes me to leave the line really slow.

 

BTW that was a 2.28 60ft time.

You guys are getting good times for stock cars ,1blackshelby what elevation are you at your getting about the same mph as me and I have the tune installed?I read on here that guys were running a jumper wire on I thing the fan to cool the rad down between rounds,does anyone know anything about this?

Steve

Link to comment
Share on other sites

You guys are getting good times for stock cars ,1blackshelby what elevation are you at your getting about the same mph as me and I have the tune installed?I read on here that guys were running a jumper wire on I thing the fan to cool the rad down between rounds,does anyone know anything about this?

Steve

I'm not sure of the elevation, but I live in southwest Missouri. I just added the SCT 3 and put 440 to the rear wheels, I think it would put more power down but the air quality was horrible, it runs much much better I can't wait to get it back to the track.

 

Also, the more power it's putting down the less wheel hop. I also only run about 3-5 gallons of 93 octane when going to the track.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...