Jump to content
TEAM SHELBY FORUM

Anyone with a GT500 read this


Guest evilchris

Recommended Posts

http://forums.bradbarnett.net/showthread.p...ight=brake+leak

 

Common issue on S197, I doubt the GT500 cap is different. Don't wait and see if yours leaks just fix it.

 

http://forums.bradbarnett.net/showthread.p...ight=brake+leak

 

I did that and used that yellow gas line tape on mine. Wasn't leaking but I KNOW it won't now.

 

Interesting.... my '92 ranger does the same thing... exact same reservoir and cap in the taurus is fine. gotta get me one of those rubber wahers.

 

.

 

fyi... here's alink to recalls and TSBs, but I couldn't find anything on this -- but that's ot suprising -- sometimes they won't issue a TSB that migh be widespread if it isn't a safety issue. Still sounds like it's worth the $.63 fix

 

I think it's funny that in 1997 they issued a TSB on my 68 mustang... whew, 29 years -- these things take time, I guess :hysterical:

Link to comment
Share on other sites

http://forums.bradbarnett.net/showthread.p...ight=brake+leak

 

Common issue on S197, I doubt the GT500 cap is different. Don't wait and see if yours leaks just fix it.

 

http://forums.bradbarnett.net/showthread.p...ight=brake+leak

 

I did that and used that yellow gas line tape on mine. Wasn't leaking but I KNOW it won't now.

 

Today I went down to Ace Hardware and bought the neopreme washer that was suggested in the above thread and put it in under the factory rubber washer and it worked. No more leak.

Rob

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...