Jump to content
TEAM SHELBY FORUM

2007 Shelby GT-500


GT500

Recommended Posts

Hello,

 

First of all I would like to say "hello" to all the people on this forum. :D

I am new here & this is my first post.

I am from Canada & have a 2007 Shelby GT-500 Coupe, white with the blue stripe package which I purchased from the USA.

 

I'm very happy with my Shelby except for one issue....wheel hop :angry:

I don't know if anyone else is experiencing this with their car & I hope I can get some answers as to how to fix this.

I've checked at a few of the SVT dealers but I was told they have never heard of such an issue.

Maybe this is due to the fact there is not enough history on this vehicle because it is new & a limited model.

 

Looking forward to receiving some advise on this issue.

Maybe there will be a Shelby upgrade sometime in the future to solve this.

 

Thanks.....Tony

Link to comment
Share on other sites

  • 3 weeks later...

Hello,

 

First of all I would like to say "hello" to all the people on this forum. :D

I am new here & this is my first post.

I am from Canada & have a 2007 Shelby GT-500 Coupe, white with the blue stripe package which I purchased from the USA.

 

I'm very happy with my Shelby except for one issue....wheel hop :angry:

I don't know if anyone else is experiencing this with their car & I hope I can get some answers as to how to fix this.

I've checked at a few of the SVT dealers but I was told they have never heard of such an issue.

Maybe this is due to the fact there is not enough history on this vehicle because it is new & a limited model.

 

Looking forward to receiving some advise on this issue.

Maybe there will be a Shelby upgrade sometime in the future to solve this.

 

Thanks.....Tony

 

Tony

Have You checked the price on them tires that You'er running. They aint cheep. how many miles You got on her.

Whats the vin#? Are You just dumping the clutch at 5000 RPM? Whats the tire pressure? What is the ambiant tempurature outside. Check owners manuel on those tires. Important information in there.

I got one red wite stripes only have 700 miles on her. waiting untill I need new tires to reayl bust lose on her. Good luck with your ride.

Link to comment
Share on other sites

  • 3 weeks later...

I pick up my convrt in Oct and have not had that issue with wheel hop... When i got on it ONCE i just cant get the tires to stick in first and second gear. the car is all over the place.

 

 

 

 

Hi Guys, I would really discuss this with the ford dealers, we just dont have any info on this, sorry

 

 

amy

Link to comment
Share on other sites

Yeah it's a known issue, at least with most current owners. There seems to be a few after market fixes but I don't know if Ford will actually ever do anything about it. I had hop real bad tonight (new years eve) on my way home from a party. Road surface seems to have a major impact on it. If its the least bit rough or uneven you get hop. It would be nice if Ford proper would do something to tweak the suspension to fix this. We need Amy to apply some pressure to Ford! ; )

 

The only other issues I know of are a few failed coils (happened to me), some coolant hose leaks due to the clamps, and a air filter problem for some very early cars. Not too bad for a first year vehicle although the hoses and hops need to be looked at closer by Ford!

 

 

Happy New Year!

 

Jason

 

BTW, Amy let me know when I can order that dash plaque! I've made the order page my internet browser homepage just so I'll hopefully notice when I can order it! ;) thx!

Link to comment
Share on other sites

:angry:

Yeah it's a known issue, at least with most current owners. There seems to be a few after market fixes but I don't know if Ford will actually ever do anything about it. I had hop real bad tonight (new years eve) on my way home from a party. Road surface seems to have a major impact on it. If its the least bit rough or uneven you get hop. It would be nice if Ford proper would do something to tweak the suspension to fix this. We need Amy to apply some pressure to Ford! ; )

 

The only other issues I know of are a few failed coils (happened to me), some coolant hose leaks due to the clamps, and a air filter problem for some very early cars. Not too bad for a first year vehicle although the hoses and hops need to be looked at closer by Ford!

Happy New Year!

 

Jason

 

BTW, Amy let me know when I can order that dash plaque! I've made the order page my internet browser homepage just so I'll hopefully notice when I can order it! ;) thx!

 

 

 

i can also testify to this problem got early aug. wheel hop even on smooth road leaving carwash with water to ease wheel speed still not fun.we have inquired with many all seem surprised at problem.have 4-speed v-8 vega funner to drive? this is wrong we love our 500 but can't impress curb fans.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...