Jump to content
TEAM SHELBY FORUM

Help Please - C&L CAI Install - Filter Shroud


MSCLCAR

Recommended Posts

Hi everyone,

 

Although I haven't chimed in very often, I've been reading the blogs in here pretty frequently for about the past year. Y'all are always a good source of information ... and now I have a question for anyone who has done the C&L CAI install.

 

I finally got my C&L CAI "Racer" kit with the X2 tuner from Doug at BamaChips. I have an '07 GT. My main question relates to the filter shroud / heat shield - Is it supposed to sit with the bottom (floor) and top edge level to the ground, or is it supposed to sit slanted foward, with the front edge (the one sitting near the radiator) a couple of inches lower than the back edge? I've looked at lots o' pictures of the system ... it's hard to tell, but I've always imagined it sitting level to the groung. Mine won't sit that way (i.e., the contours of the shroud don't fit to the contours of the top of the wheel well if you try to make it sit level).

 

At first, I thought they might have sent me the wrong shroud, but Doug says that the shrouds for all of the different systems (for V6, GT, etc.) are the same. Maybe it's just the fact that I've always imagined it sitting in there with the floor of the shroud level to the ground (it just looks weird to me leaning forward), but I've actually started wondering whether my car (an '07 delivered in March) has a differently shaped wheel well or a mounting hole in a different location.

 

I've attached pictures so you can see what I'm talking about. As you can see in the picture below, the lip where it mounts to the wheel well is slanted upward compared to the bottom floor and top edge. And since the mounting location above the wheel well sits pretty much level to the ground, it makes it impossible for the shroud to sit level once you bolt it down.

 

post-9331-1186417857_thumb.jpg

 

Let me know your thoughts.

 

Also, even with it installed slanting forward, the lines you can see in the lower left corner of the picture below seem to be in the way. Are those my ABS lines? The C&L instructions say that the ABS lines may be in the way and that I should "pull the rearmost ABS lines towards the forward of the vehicle so that they clear the bottom of the filter shroud." They are certainly in the way, but it seems to be the front edge (not the bottom) that is having clearance problems. And the instructions say that "they should move easily, and not require any real effort." If those lines in the lower left corner of my picture are the ABS lines of which they speak, they are hard (metal) and don't budge. Are the instructions implying that the nuts holding them in place should be loosened and that then they will swing a little out of the way without any real effort?

 

post-9331-1186417870_thumb.jpg

 

I hope all of that makes sense. I don't know if any of you have encountered these same things, but I'll appreciate any help / information / suggestions y'all can offer. Thanks in advance.

post-9331-1186417857_thumb.jpg

post-9331-1186417870_thumb.jpg

Link to comment
Share on other sites

Update:

 

I finally got in touch with someone at C&L. They confirmed that the shroud is supposed to sit slanted. It just wasn't how I'd pictured it, but I can see how that works now.

 

So the only problem now is that it seems that my ABS lines don't want to move like they usually do. The tech at C&L said they usually just pivot/swing out of the way with little effort. It looks like my setup may be a little different for some reason. The lines are actually clamped down in several places, preventing them from swinging. I should be able to figure that out, though. I can either play with the clamps and try to free them up, or I can just cut slots into the shroud.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...
...